BlackBerry App World 1.1.0.11 と Yatca の非互換性問題

Yatca - MissingResourceException

BlackBerry App World 1.1.0.11 または、同 1.1.0.15 をインストールした状態で Twitter クライアントアプリ Yatca を起動すると

Uncaught exception: net.rim.device.api.i.18n. MissingResourceException

というエラーが表示され Yatca が起動出来なくなります。
Yatca のサイトを見ると

App World 1.1.0.11 incompatible with Yatca

Installing the latter seems to change the behaviour of the message list integration APIs that are vital to the successful operation of Yatca.

App World 1.1.0.11 の "message list integration APIs" の変更にによる、 App World と Yatca の非互換性により発生している様です。

App World 1.1.0.11 breaks message list integration APIs?

早急な解決方法としては
・App World を削除する(Yatca お勧め)
・Yatca 以外の Twitter クライアントへ鞍替えする
・BlackBerry で Twitter を使わない

3つ目は究極な選択ですが、現状、CrackBerry や GetJar 等の App World 以外のアプリストアや OTA インストールという方法もありますので、自分は App World を削除しました。

しかし、App Wold を削除する事で Yatca が正常に動作していたのですが、どういう事なのか、1日経ったら Yatca からタイムラインの取得が Time Out する状況になってしまいました。

自分の環境下では、Yatca だけがエラーに見舞われていますが、世には色々なアプリがあります。
憶測ではありますが、もしかしたら、他にも同様のエラーが発生するアプリもあるかもしれません。もし、そのアプリが気に入っている、ライフストリームに組み込まれていて切り離せな等の場合、App World を削除する事を考慮に入れてみる必要があるかもしれません。

BlackBerry App World
CrackBerry.com
GetJar
Yatca

Appshocker
bitFlyer ビットコインを始めるなら安心・安全な取引所で
ビットコイン取引高日本一の仮想通貨取引所 coincheck bitcoin